Oficjalne Forum programu Odkurzacz
Strony: [1] 2   Do dołu
  Odpowiedz  |  Drukuj  
Autor Wątek: Problem z opcją "Cytuj"  (Przeczytany 6115 razy)
0 użytkowników i 1 Gość przegląda ten wątek.
cezar39
Srebro
**
Offline Offline

Płeć: Mężczyzna
Wiadomości: 551


Windows 7 SP1 x64 bit


« : Marzec 25, 2010, 16:58:21 »
Odpowiedz cytującCytuj

Znalazłem dość poważny problem z forum. Opcja "Cytuj" działa mi tylko na Firefox (3.6.2), natomiast z Opery (10.51) i Chrome (4.1) pokazuje się zielony pasek na górze i cały czas ładuje. Internet Explorer specjalnie pominąłem, gdyż tam w ogóle wszystko źle wygląda xD. Czy u Was też jest ten błąd, czy może to coś u mnie jest nie tak?
Zapisane
pakeroso
Srebro
**
*
Offline Offline

Płeć: Mężczyzna
Wiadomości: 416


Prezes


« Odpowiedz #1 : Marzec 25, 2010, 17:26:36 »
Odpowiedz cytującCytuj

Też jest smile
Zapisane

ArturM
Srebro
**
*
Offline Offline

Płeć: Mężczyzna
Wiadomości: 554


WWW
« Odpowiedz #2 : Marzec 25, 2010, 17:46:07 »
Odpowiedz cytującCytuj

Miejmy nadzieję, że SMF 2.0 będzie działać lepiej :D Puki co dostępna jest wersja RC3. Oby stabilna wyszła jak szybciej.
Zapisane

xvix5
Gość
« Odpowiedz #3 : Marzec 25, 2010, 17:56:17 »
Odpowiedz cytującCytuj

Opera 10.51 nie dziala, Chrome 5 nie dziala, FF nie chce mi się sciagac
Zapisane
cezar39
Srebro
**
Offline Offline

Płeć: Mężczyzna
Wiadomości: 551


Windows 7 SP1 x64 bit


« Odpowiedz #4 : Marzec 25, 2010, 18:58:23 »
Odpowiedz cytującCytuj

Ale kiedyś działało na Chrome 2 albo 3 już nie pamiętam. Ale ważne, że to zgłoszone, admini wiedzą o błędzie.
Zapisane
Franmo
Constructor
Diament
****
*
Offline Offline

Płeć: Mężczyzna
Wiadomości: 3421



« Odpowiedz #5 : Marzec 25, 2010, 22:23:39 »
Odpowiedz cytującCytuj

Potwierdzam na Operze 10.51. Cytowanie w żaden sposób nie chce działać... pozostaje ręczne cytowanie... lub Firefox :P
Niestety to wina ewidentna ze strony SMF. Trzeba czekać na aktualizację.
Zapisane
cezar39
Srebro
**
Offline Offline

Płeć: Mężczyzna
Wiadomości: 551


Windows 7 SP1 x64 bit


« Odpowiedz #6 : Marzec 31, 2010, 22:09:33 »
Odpowiedz cytującCytuj

Więc problem jest na wersji SMF 1.1.11. Zobaczymy, jak będzie na nowszych wersjach.
Zapisane
Franmo
Constructor
Diament
****
*
Offline Offline

Płeć: Mężczyzna
Wiadomości: 3421



« Odpowiedz #7 : Listopad 11, 2010, 22:54:23 »
Odpowiedz cytującCytuj

Wyszła i została wdrożona na forum wersja 1.1.12.
Ciekawe jak z tą funkcją "Cytuj". Opera też nowsza wyszła.

Ja w sumie Opery nie używam, musiałbym zainstalować żeby przetestować :P
Zapisane
xvix
Żelazo
*****
Offline Offline

Wiadomości: 164


« Odpowiedz #8 : Listopad 12, 2010, 12:04:05 »
Odpowiedz cytującCytuj

Niestety, nie działa :/
Zapisane
Alvinek
Global Moderator
Platyna
*
*
Offline Offline

Płeć: Mężczyzna
Wiadomości: 956


Alvinko Portabler


« Odpowiedz #9 : Grudzień 24, 2010, 19:56:20 »
Odpowiedz cytującCytuj

Mogę sobie zaśmiecić kompa przeglądarkami żeby powiedzieć wam czy działa. I tak zrobie.

Google Chrome:
Wersja: 8
Stan wyglądu forum: 5\5
Funkcja "Cytuj": Nie działa

Internet Explorer:
Wersja: 8
Stan wyglądu forum: 2\5
Funkcja "Cytuj": Nie działa

Internet Explorer:
Wersja: 9
Stan wyglądu forum: 2/5 << zgłoszono problem z wyświetlaniem.
Funkcja "Cytuj": Nie działa

Opera:
Wersja: 11
Stan wyglądu forum bez "Turbo": 5\5
Stan wyglądu forum z "Turbo": 5\5 << jest jednak trochę grafiki, Opera wszystko ładnie układa.
Funkcja "Cytuj": Nie działa!
Problem jest natomiast podczas zmiany koloru, wyboru emotek, wszystkiego. << Problem stoi po funkcji "Turbo" - jeśli włączona problem jest.



Mozilla Firefox Wersja Stabilna:
Wersja: 3
Stan wyglądu forum: 5/5
Funkcja "Cytuj": Działa

Mozilla Firefox Wersja Beta:
Wersja: 4
Funkcja "Cytuj": Działa

Obecnie tworzę program "Cytat-Help" który pomaga w wyświetlaniu funkcji "Cytuj". Działa on na podporach, czyli dodaje te kolumienki: Quote, sprawdza co jest napisane w wiadomości cytowanej, przemieszcza na daną strone i mamy cytat. Ale niestety po teście na IE 9 jakimś cudem ten IE 9 nie chciał się włączyć, więc programu nie udostępnie dopóki nie znajdę linijki po której stoi problem  confused1
« Ostatnia zmiana: Grudzień 26, 2010, 12:28:51 wysłane przez Alvinek34 » Zapisane

Franmo
Constructor
Diament
****
*
Offline Offline

Płeć: Mężczyzna
Wiadomości: 3421



« Odpowiedz #10 : Grudzień 25, 2010, 15:52:20 »
Odpowiedz cytującCytuj

Opcja cytuj / poprawność wyświetlania
IE8 - źle / źle
IE9 BETA - źle / źle
Chrome - źle / ok
FireFox 3.6.x - ok / ok
Zapisane
ArturM
Srebro
**
*
Offline Offline

Płeć: Mężczyzna
Wiadomości: 554


WWW
« Odpowiedz #11 : Marzec 18, 2012, 14:18:52 »
Odpowiedz cytującCytuj

Ponieważ ani w Chrome ani w IE8 nie działa opcja "Cytuj" (czego w przypadku SMF 2.0 nie można powiedzieć), to czy mógłby ktoś w znaczniku "code" pokazać, jak wyglada kod cytowania z uwzględnieniem autora i czasu napisania oryginalnego posta?

Bo bardzo chciałbym móc cytować tak jak Franmo tutaj: http://forum.odkurzacz.prohost.pl/index.php?topic=356.msg15561#msg15561 - że "Cytat: <autor> <data> o <godzina:minuty:sekundy>".
« Ostatnia zmiana: Marzec 18, 2012, 14:56:09 wysłane przez ArturM » Zapisane

Franmo
Constructor
Diament
****
*
Offline Offline

Płeć: Mężczyzna
Wiadomości: 3421



« Odpowiedz #12 : Marzec 18, 2012, 19:58:06 »
Odpowiedz cytującCytuj

Jeśli klikam "Cytuj" to generuje mi się takie coś:

Kod:
[quote author=ArturM link=topic=3323.msg15573#msg15573 date=1332076732]

gdzie dla twojego powyższego posta link to:
...forum.odkurzacz.prohost.pl/index.php? [odcinamy] topic=3323.msg13718#msg13718

data to liczba powstała przez konwersję aktualnej daty minus data z kiedyś (01.01.1970). Tu będzie ciężko wyliczyć.

Czyli pokrywa się to mniej więcej tak:
cytowany tekst
Kod:
[quote author=NazwaAutora link=topic=3323.msg13718#msg13718 date=1]cytowany tekst[/quote]

ps. Poszukam jakiegoś rozwiązania na to cytowanie, bo nie wiem kiedy weźmiemy się z Unicornem i przeniesiemy na SMF2.
« Ostatnia zmiana: Marzec 18, 2012, 20:06:04 wysłane przez Franmo » Zapisane
ArturM
Srebro
**
*
Offline Offline

Płeć: Mężczyzna
Wiadomości: 554


WWW
« Odpowiedz #13 : Marzec 18, 2012, 20:28:14 »
Odpowiedz cytującCytuj

Bez "date=x" nie działa podlinkowanie ("link=x" wyświetlane jako tekst). Dlatego chyba jednak poprzestanę na [ quote ] (bo z rokiem 1970 jakoś tak dziwnie), ewentualnie z samym author
Cytat: NazwaAutora
cytowany tekst
Wtedy jak najbardziej ok.
« Ostatnia zmiana: Marzec 18, 2012, 20:34:47 wysłane przez ArturM » Zapisane

Alvinek
Global Moderator
Platyna
*
*
Offline Offline

Płeć: Mężczyzna
Wiadomości: 956


Alvinko Portabler


« Odpowiedz #14 : Marzec 18, 2012, 20:54:29 »
Odpowiedz cytującCytuj

W ogole to cytowanie w SMF 1.1.x jest dziwne. Tak przy okazji wy też macie zakładkę admin w której nic nie ma? :D
Zapisane

Strony: [1] 2   Do góry
  Odpowiedz  |  Drukuj  
 
Skocz do:  

+ Szybka odpowiedź
W szybkiej odpowiedzi możesz użyć kodów BBC i uśmieszków tak jak przy normalnej odpowiedzi.